Version 1.16/1.17 Tech Note: Driver Fails to Start

Modified on Thu, 26 Mar at 2:28 PM

Summary

After the file scan completes, the driver fails to start and reports error 1359.  The root cause is a corrupted Windows registry value:

HKLM\SYSTEM\CurrentControlSet\Control\Windows\SystemDirectory


On the affected system, this value was incorrectly set to:

C:\Windows\SysWOW64


Impact

Driver fails to start.


Root Cause

The SystemDirectory registry value must point to the 64 bit system directory %SystemRoot%\System32


Resolution

  1. Correct the registry value at:
    HKLM\SYSTEM\CurrentControlSet\Control\Windows\SystemDirectory
  2. Set the value to: %SystemRoot%\System32
  3. Reboot the system.
  4. Verify the driver started by opening a command prompt and executing the command ‘sc query aztagent

 


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